Issue with Signadot Website

Incident Report for Signadot

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 18:53 UTC

Identified

We've identified the issue and are currently monitoring our service providers as they work on a fix.
This impacts signadot.com, but all other systems, including the dashboard and APIs, remain fully operational.
Posted Oct 20, 2025 - 16:12 UTC