Issues with SSO authentication

Incident Report for Signadot

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 11:03 UTC

Identified

We've confirmed a service disruption impacting user authentication via certain external providers, including Okta. This issue appears to be a direct ripple effect of the ongoing major AWS regional outage (US-EAST-1 or similar).
Posted Oct 20, 2025 - 08:23 UTC
This incident affected: UI (app.signadot.com).